Welcome to Image2Lcd

感谢您使用Image2Lcd

Image2Lcd 是一款工具软件，它能使你把各种来源的图片转换成特定的数据格式以用来匹配单片机系统所需要的显示数据格式。Image2Lcd支持的输入图像格式包括： BMP, WBMP, JPG, GIF, WMF, EMF, ICO, 等等。Image2Lcd的输出数据类型包括定制的二进制类型、C语言数组类型和标准的BMP格式、WBMP格式。Image2Lcd能可视调节输入图象的数据扫描方式、灰度(颜色数)、图像数据排列方式、亮度、对比度、等等。对于包含了图像头数据保存的图像数据文件，Image2Lcd能重新打开作为输入图像。

特点

  • 支持所有的点阵LCD所需要的特殊显示数据格式。
  • 可视调节输出图像效果。
  • 256色模式下支持用户调色板(TIFF格式)。
  • 支持4096色图像输出。
  • 以二进制类型和C语言数组类型(文本)两种方式保存数据，方便单片机开发者的不同需要。
  • 保存的数据支持LSB First/MSB First(很多单片机系统WORD高低字节排列与PC相反)。
  • 可以保存图像为指定颜色数的BMP格式图像。
  • 即时图示当前设置的数据格式。


窗口界面介绍

Image2Lcd 窗口界面如下图所示：

Image2Lcd窗口包含工具条、图像设置区、图像显示区、图像调整区、状态条。

工具条：
工具条包含有按钮：打开、保存、设置、重新载入、上一幅、下一幅、帮助、关于。

  • 打开：打开图像文件作为输入图像。
  • 保存：以当前设置的格式保存输出图像数据。
  • 设置：启动设置对话框。
  • 重新载入：重新打开输入图像，并按照当前设置转换成输出图像。
  • 上一幅：打开当前图像所在目录中的上一幅图像。
  • 下一幅：打开当前图像所在目录中的下一幅图像。
  • 帮助：启动帮助文档。
  • 关于：启动关于对话框。

图像设置区：
设置区包含一组用来设置输出图像格式的控件，在顶部的方框中图像是当前设置的图像数据格式的图解说明。详细说明见设置输出图像格式。

图像显示区：
图像显示区分为左右两个部分，左边的部分显示输入图像，右边的部分显示输出图像，输出图像是由输入图像按照当前设置的数据格式转变得到显示数据并显示。如果输入图像超过用户设置的最大宽度或最大高度。输入图像将被比例缩小到最大宽度和最大高度之内。

图像调整区：
图像调整区有页面：输出图像调整、256色、16位彩色、18位彩色、24位彩色、32位彩色，在未注册状态下还有页面：注册。

  • 输出图像调整：调整输出图像的显示效果。
  • 256色：设置256色下的调色板。
  • 4096色：设置4096色下的RGB颜色排列。
  • 16位彩色：设置16位彩色下的RGB颜色排列。
  • 18位彩色：设置18位彩色下的RGB颜色排列。
  • 24位彩色：设置24位彩色下的RGB颜色排列。
  • 32位彩色：设置32位彩色下的RGB颜色排列。
  • 注册：注册Image2Lcd软件。

状态条：
状态条显示输入图像和输出图像的信息,左边部分显示输入图像名和原始图片的宽度和高度，右边部分显示输出图像的宽度和高度。


设置对话框

设置对话框界面如下图所示：

设置对话框包含两项设置内容。

在资源管理器右键菜单中设置关连菜单：
这一项选中后，在资源管理器中的图像文件名上点击右键后出现的菜单中添加一项“Image2Lcd”。选中该项将启动Image2Lcd打开该图像文件。

保存为(*.C)文件后使用记事本打开：
在输出数据类型为“C语言数组(*.C)”时, 在保存输出数据后，输出数据文件使用记事本打开显示。


设置输出图像格式

输出图像格式包含如下设置内容：

输出数据类型：
可以选择的项有：“二进制(*.bin)”，“C语言数组(*.c)”，“BMP格式(*.bmp)”，“WBMP格式(*.wbmp)”。

扫描模式：
可以选择“水平扫描/垂直扫描/数据水平,字节垂直/数据垂直,字节水平”中的一种。

输出灰度：
可以选择“单色/4灰/16灰/256色/4096色/16位真彩色/18位真彩色/24位真彩色/32位真彩色”中的一种。

最大宽度、最大高度：
设置输出图像的最大宽度和高度，点击紧靠着的箭头按钮或重新载入按钮使当前打开的图像适应新设置的最大宽度和最大高度。

包含图像头数据：
在输出数据类型为“二进制(*.bin)”或“C语言数组(*.c)”时保存的图像数据包含有图像头数据，只有包含了图像头数据的文件Image2Lcd才能重新打开显示。详见图像头数据结构。

字节内象素数据反序：
在“单色/4灰/16灰”时字节内的象素数据从低位向高位排列。

自右至左扫描：
扫描模式的附加选项，影响输出图像数据排列方式。当前使用的数据排列见窗口左上方的示意图。

自底至顶扫描：
扫描模式的附加选项，影响输出图像数据排列方式。当前使用的数据排列见窗口左上方的示意图。

高位在前(MSB First)：
使保存的数据中WORD类型的数据高低位字节颠倒(和PC中的高低位字节相反)。很多微处理器对WORD类型的高低位字节顺序定义和PC(X86 CPU)相反，此时选中此项，在微处理器中读出WORD类型数据时就可以直接使用而不需要颠倒高低字节了。


图像头数据结构

Image2Lcd保存的图像数据组织方式为：图像头数据-调色板数据-图像数据。

“单色/4灰/16灰/256色”的图像数据头如下：

typedef struct _HEADGRAY
{
unsigned char scan;
unsigned char gray;
unsigned short w;
unsigned short h;
}HEADGRAY;

scan: 扫描模式

  • Bit7: 0:自左至右扫描，1:自右至左扫描。
  • Bit6: 0:自顶至底扫描，1:自底至顶扫描。
  • Bit5: 0:字节内象素数据从高位到低位排列，1:字节内象素数据从低位到高位排列。
  • Bit4: 0:WORD类型高低位字节顺序与PC相同，1:WORD类型高低位字节顺序与PC相反。
  • Bit3~2: 保留。
  • Bit1~0: [00]水平扫描，[01]垂直扫描，[10]数据水平,字节垂直，[11]数据垂直,字节水平。
gray: 灰度值

灰度值，1:单色，2:四灰，4:十六灰，8:256色，12:4096色，16:16位彩色，24:24位彩色，32:32位彩色。

w: 图像的宽度。

h: 图像的高度。

“4096色/16位真彩色/18位真彩色/24位真彩色/32位真彩色”的图像数据头如下：

typedef struct _HEADCOLOR
{
unsigned char scan;
unsigned char gray;
unsigned short w;
unsigned short h;
unsigned char is565;
unsigned char rgb;
}HEADCOLOR;

scan、gray、w、h与HEADGRAY结构中的同名成员变量含义相同。

is565: 在4096色模式下为0表示使用[16bits(WORD)]格式，此时图像数据中每个WORD表示一个象素；为1表示使用[12bits(连续字节流)]格式，此时连续排列的每12Bits代表一个象素。
在16位彩色模式下为0表示R G B颜色分量所占用的位数都为5Bits，为1表示R G B颜色分量所占用的位数分别为5Bits,6Bits,5Bits。
在18位彩色模式下为0表示"6Bits in Low Byte"，为1表示"6Bits in High Byte"。
在24位彩色和32位彩色模式下is565无效。

rgb: 描述R G B颜色分量的排列顺序，rgb中每2Bits表示一种颜色分量，[00]表示空白，[01]表示Red，[10]表示Green，[11]表示Blue。

“256色”的调色板数据结构如下：

typedef struct _PALENTRY
{
unsigned char red;
unsigned char green;
unsigned char blue;
}PALENTRY;

typedef struct _PALETTE
{
unsigned short palnum;
PALENTRY palentry[palnum];
}PALETTE;

仅在256色模式下存在调色板数据结构,调色板数据结构紧跟在数据结构HEADGRAY之后。


图像数据说明

Image2Lcd保存的图像数据组织方式为：图像头数据-调色板数据-图像数据。
图像头数据和调色板数据的格式见图像头数据结构。
当前设置的图像格式的数据排列方式在程序界面的左上角有图形描述。
图像数据的排列方式受 扫描模式、字节内象素数据反序、自右至左扫描、自底至顶扫描等设置的影响。
设置中选择“字节内象素数据反序”表示灰度图像数据的字节内部图像数据从低位向高位顺序排列，否则图像数据从高位向低位顺序排列。
设置中选择“自右至左扫描”表示图像数据从图像的右边开始向左边方向排列，否则图像数据从图像的左边开始向右边方向排列。
设置中选择“自底至顶扫描”表示图像数据从图像的底部开始向顶部方向排列，否则图像数据从图像的顶部开始向底部方向排列。

“单色”的图像数据：

单色图像数据一个象素使用一个位(1 Bit)表示，0表示白色，1表示黑色。由于数据的最小存储单位是字节，每个字节有8个位，当图像的宽或高不是8的倍数时，图像数据的宽或高将补0扩充到8的倍数以吻合字节宽度(具体是宽度还是高度取决于扫描模式)。

“4灰”的图像数据：

4灰图像数据一个象素使用两个位(2 Bit)表示，00表示白色，01表示浅灰色，10表示深灰色，11表示黑色。由于数据的最小存储单位是字节，每个字节有8个位，当图像的宽或高不是4的倍数时，图像数据的宽或高将补0扩充到4的倍数以吻合字节宽度(具体是宽度还是高度取决于扫描模式)。

“16灰”的图像数据：

16灰图像数据一个象素使用四个位(4 Bit)表示，图像数据[0X00~0X0F]代表的颜色从白色到黑色渐变。由于数据的最小存储单位是字节，每个字节有8个位，当图像的宽或高不是2的倍数时，图像数据的宽或高将补0扩充到2的倍数以吻合字节宽度(具体是宽度还是高度取决于扫描模式)。

“256色”的图像数据：

256色图像数据一个象素使用一个字节表示。图像数据的每个字节记录的是对应的象素在调色板中的条目， 调色板中每一条目都记录了一种用RGB描述的颜色。调色板条目个数最大值为256个(0~255)。调色板在256色数据调整中设置。

“4096色”的图像数据：

4096色图像数据一个象素使用12个位(12 Bits)表示。该12Bits记录了对应的象素RGB颜色。 R G B颜色分量分别占用4Bits，排列顺序由4096色数据调整设置。

“16位真彩色”的图像数据：

16位真彩色图像数据一个象素使用一个WORD(2 Bytes)表示。图像数据的每个WORD记录了对应的象素RGB颜色。 R G B颜色分量数值在WORD中的位置由16位彩色数据调整设置。WORD类型数据同时 受设置“WORD高字节低地址”的影响，选中此项将使WORD的高低字节顺序与PC定义相反。

“18位真彩色”的图像数据：

18位真彩色图像数据一个象素使用3个Byte表示。这3个Byte数据分别记录了象素的RGB颜色分量。 R G B颜色分量数值在3个Byte中的位置排列由18位彩色数据调整设置。

“24位真彩色”的图像数据：

24位真彩色图像数据一个象素使用三个字节(3 Bytes)表示。图像数据的每三个字节记录了对应的象素RGB颜色。 R G B颜色分量分别占用一个字节，排列顺序由24位彩色数据调整设置。

“32位真彩色”的图像数据：

32位真彩色图像数据一个象素使用四个字节(4 Bytes)表示。图像数据的每四个字节记录了对应的象素RGB颜色。 R G B颜色分量分别占用一个字节，另一个字节为0。排列顺序由32位彩色数据调整设置。


输出图像调整

输出图像调整的界面部分如下图显示：

恢复缺省值
点击恢复缺省值按钮使输出图像调整参数回到缺省设置，即正常显示、颜色不反转、亮度和对比度等同输入图像。

颜色反转
颜色反转单选框被选中后，输出图像的颜色数据被做取反操作。

显示方式
右上角的下拉框中列出了四种可选输出图像显示方式：正常显示、左右颠倒、上下颠倒和左右上下颠倒。

亮度
拖动亮度滑块调整输出图像的亮度。

对比度
拖动对比度滑块调整输出图像的对比度。


256色数据调整

256色数据调整的界面部分如下图显示：

调色板选择
可选择RGB332调色板、灰度调色板、用户调色板。其中用户调色板是用户指定的调色板文件(TIFF格式)。当前选择的调色板的颜色顺序在下部的色条中被显示。

输出图像数据中包含调色板数据
256色图像数据只有配合调色板数据才能正常显示(LCD控制器使用默认的调色板时例外)，建议用户选上此项。当LCD控制器支持RGB332格式的8位颜色数据时，选择 RGB332调色板、不选 输出图像数据中包含调色板数据，此时图像数据正好吻合RGB332格式。调色板数据结构见图像头数据结构中的说明。

载入调色板
该按钮用来打开一个调色板文件(*.PAL)作为用户调色板。打开的用户调色板文件名将显示在左边的编辑框中。用户也能使用256色的BMP文件(*.BMP)作为调色板文件打开。

保存调色板
用来保存当前选择的调色板数据为TIFF格式(*.PAL)文件。

调色板直观图
用来直观显示当前选择的调色板的颜色顺序。


4096色数据调整

4096色数据调整的界面部分如下图显示：

恢复缺省值
点击恢复缺省值按钮使调整参数回到缺省设置，即颜色位数为16Bits(WORD)，颜色数据排列由高位到低位依此为NULL,Red,Green,Blue。

颜色位数
4096色图像数据每一象素使用一个12Bits数据来表示，每4Bits数据记录象素的红绿蓝颜色分量中的一种，Image2Lcd支持两种应用普遍的颜色位数格式，分别是[12bits(连续字节流)]和[16bits(WORD)]，其中第二种格式会使WORD中剩余4Bits，称为空白位，空白位在颜色数据排列图中以白色表示。

颜色数据排列
图示4096色图像的一个象素数据从高位到低位的颜色分量排列顺序。用鼠标拖动颜色块来改变排列方式。颜色位数为[16bits(WORD)]时，作为WORD型数据，在保存时还将受设置输出图像格式中的“高位在前(MSB First)”影响。


16位彩色数据调整

16位彩色数据调整的界面部分如下图显示：

恢复缺省值
点击恢复缺省值按钮使调整参数回到缺省设置，即颜色位数为[R:5bits,G:6bits,B:5bits]，颜色数据排列由高位到低位依此为Red,Green,Blue。

颜色位数
16位彩色图像数据每一象素使用一个WORD数据来表示，这个WORD数据中记录了象素的红绿蓝三种颜色分量的值，Image2Lcd支持两种应用普遍的颜色位数格式，分别是[R:5bits,G:6bits,B:5bits]和[R:5bits,G:5bits,B:5bits]，其中第二种格式会使WORD中剩余一bit，称为空白位，空白位在颜色数据排列图中以白色表示。

颜色数据排列
图示16位彩色一个WORD图像数据从高位到低位的颜色分量排列顺序。用鼠标拖动颜色块来改变排列方式。作为WORD型数据，在保存时还将受设置输出图像格式中的“高位在前(MSB First)”影响。


18位彩色数据调整

18位彩色数据调整的界面部分如下图显示：

恢复缺省值
点击恢复缺省值按钮使调整参数回到缺省设置，即颜色位数为"6Bits in Low Byte"，颜色数据排列由高位到低位依此为Blue,Green,Red。

颜色位数
18位彩色图像数据每一象素使用3个Byte数据来表示，这3个Byte数据分别记录了象素的红绿蓝三种颜色分量的值，由于每种颜色分量只使用了6个Bits，每个Byte还多出2个Bits，称为空白位，空白位在颜色数据排列图中以白色表示。 空白位的位置随颜色位数设置而改变，当选"6Bits in Low Byte"时，空白位在字节的高2位，当选"6Bits in High Byte"时，空白位在字节的低2位。

颜色数据排列
图示18位彩色一个象素的图像数据(3Bytes)的颜色分量排列顺序。用鼠标拖动颜色块来改变排列方式。输出的图像数据将按图示的颜色分量的排列方式来组织数据。


24位彩色数据调整

24位彩色数据调整的界面部分如下图显示：

恢复缺省值
点击恢复缺省值按钮使24位彩色图像的颜色数据排列回到缺省设置，即Blue,Green,Red的顺序。

颜色数据排列
24位彩色的图像数据每一象素对应24bits即三个字节，其中每个字节对应一种颜色分量。在图示中从左到右依此为bytes[0~2]所代表的颜色分量，使用鼠标拖动颜色块来改变排列方式。


32位彩色数据调整

32位彩色数据调整的界面部分如下图显示：

恢复缺省值
点击恢复缺省值按钮使32位彩色图像的颜色数据排列回到缺省设置，即Blue,Green,Red,空白位的顺序。

颜色数据排列
32位彩色的图像数据每一象素对应32bits即四个字节，其中三个字节对应一种颜色分量，一个字节不用称为空白位。空白位在图中以白色表示。图示中从左到右依此为bytes[0~3]所代表的颜色分量或空白位，可以使用鼠标拖动颜色块来改变排列方式。


安装说明

下载了Image2Lcd安装程序后，解压缩数据并双击Setup程序，按照提示完成安装步骤就可以了。

Image2Lcd安装后将在开始菜单的程序组和桌面上出现菜单项或图标，这时Image2Lcd处于没有注册的状态。对于已经获得注册码的用户，运行Image2Lcd程序并输入注册码后程序转入注册状态。


运行环境

Image2Lcd对系统有如下要求：

  • 中文版本的Windows95/98/2000/NT/XP。
  • 奔腾133M以上的CPU。
  • 32M以上的内存。
  • 16位颜色以上的彩色模式。
  • IE5.0以上的版本。
  • DirectX 5.0以上的版本。
  • 鼠标必备。


卸载

有两种方法可以卸载Image2Lcd。

控制面板
运行控制面板程序，双击添加/删除程序，在添加/删除程序的列表框中找到Image2Lcd条目并双击，或选中Image2Lcd条目后点击添加/删除按钮。

开始菜单
打开开始菜单，依此打开程序、Image2Lcd，然后运行Uninstall Image2Lcd。


如何注册

Image2Lcd的未注册版本关于注册的页面如下图显示：

访问注册网页
点击该链接将启动IE窗口并链接到Image2Lcd的注册网页，通过注册网页来申请注册获得注册码。

访问作者主页
点击该链接将启动IE窗口并链接作者的的主页，用户可以访问作者主页来了解Image2Lcd的升级信息和得到技术支持。

给作者发邮件
有关于Image2Lcd的问题、建议欢迎发邮件给作者。

注册码
当通过注册网页注册并收到注册码邮件后把收到的注册码填入注册码编辑框，点击[注册]按钮来完成注册。

注册
[注册]按钮用来在填好注册码后的注册。当注册码无误时Image2Lcd提示成功注册信息，当注册码不正确时提示出错信息。

Image2Lcd的一个注册码只授权给一台PC使用，未注册的版本将在输入输出图像上加上“Image2Lcd”字样，注册后该字样将立即永久消失。注册后请保存好您的注册码，以备重新安装Image2Lcd之用。另外，打开About对话框可以看到注册情况的信息显示。


联系作者

技术支持: wwwbbbjjj@sohu.com
注册销售: 进入注册网页

升级信息请关注:
http://www.wbj3000.com


License

END-USER LICENSE AGREEMENT FOR THIS SOFTWARE

This End-User License Agreement ("EULA") is a legal agreement between you (either an individual or a single entity) and the mentioned author of this Software for the software product identified above, which includes computer software and may include associated media, printed materials, and "online" or electronic documentation ("SOFTWARE PRODUCT"). By installing, copying, or otherwise using the SOFTWARE PRODUCT, you agree to be bound by the terms of this EULA. If you do not agree to the terms of this EULA, do not install or use the SOFTWARE PRODUCT.

SOFTWARE PRODUCT LICENSE
The SOFTWARE PRODUCT is protected by copyright laws and international copyright treaties, as well as other intellectual property laws and treaties. The SOFTWARE PRODUCT is licensed, not sold.

1. GRANT OF LICENSE. This EULA grants you the following rights:Installation and Use. You may install and use an unlimited number of copies of the SOFTWARE PRODUCT.

Reproduction and Distribution. You may reproduce and distribute an unlimited number of copies of the SOFTWARE PRODUCT; provided that each copy shall be a true and complete copy, including all copyright and trademark notices, and shall be accompanied by a copy of this EULA. Copies of the SOFTWARE PRODUCT may be distributed as a standalone product or included with your own product.

2. DESCRIPTION OF OTHER RIGHTS AND LIMITATIONS.

Limitations on Reverse Engineering, Decompilation, and Disassembly. You may not reverse engineer, decompile, or disassemble the SOFTWARE PRODUCT, except and only to the extent that such activity is expressly permitted by applicable law notwithstanding this limitation.

Separation of Components.
The SOFTWARE PRODUCT is licensed as a single product. Its component parts may not be separated for use on more than one computer.

Software Transfer.
You may permanently transfer all of your rights under this EULA, provided the recipient agrees to the terms of this EULA.

Termination.
Without prejudice to any other rights, the Author of this Software may terminate this EULA if you fail to comply with the terms and conditions of this EULA. In such event, you must destroy all copies of the SOFTWARE PRODUCT and all of its component parts.

Distribution.
The SOFTWARE PRODUCT may not be sold or be included in a product or package which intends to receive benefits through the inclusion of the SOFTWARE PRODUCT. The SOFTWARE PRODUCT may be included in any free or non-profit packages or products.

3. COPYRIGHT.
All title and copyrights in and to the SOFTWARE PRODUCT(including but not limited to any images, photographs, animations, video, audio, music, text, and "applets" incorporated into the SOFTWARE PRODUCT), the accompanying printed materials, and any copies of the SOFTWARE PRODUCT are owned by the Author of this Software. The SOFTWARE PRODUCT is protected by copyright laws and international treaty provisions. Therefore, you must treat the SOFTWARE PRODUCT like any other copyrighted material except that you may install the SOFTWARE PRODUCT on a single computer provided you keep the original solely for backup or archival purposes.

LIMITED WARRANTY

NO WARRANTIES.
The Author of this Software expressly disclaims any warranty for the SOFTWARE PRODUCT. The SOFTWARE PRODUCT and any related documentation is provided "as is" without warranty of any kind, either express or implied, including, without limitation, the implied warranties or merchantability, fitness for a particular purpose, or noninfringement. The entire risk arising out of use or performance of the SOFTWARE PRODUCT remains with you.

NO LIABILITY FOR DAMAGES.
In no event shall the author of this Software be liable for any damages whatsoever (including, without limitation, damages for loss of business profits, business interruption, loss of business information, or any other pecuniary loss) arising out of the use of or inability to use this product, even if the Author of this Software has been advised of the possibility of such damages.

LIMITATIONS OF UNREGISTERED VERSION

You can use the SOFTWARE PRODUCT for evaluation purposes. The unregistered copy of SOFTWARE PRODUCT will add a mark (Image2Lcd) when you converted and saved images.

REGISTRATION

The SOFTWARE PRODUCT is not a free software. You are licensed to use one copy of SOFTWARE PRODUCT, on one (1) computer or workstation. See the SOFTWARE PRODUCT web site at http://www.wbj3000.com for more information about online ordering. When payment is received you will be sent a registration number of latest version of SOFTWARE PRODUCT.