Welcome to Image2Lcd

感謝您使用Image2Lcd

Image2Lcd 是一款工具軟體，它能使你把各種來源的圖片轉換成特定的數據格式以用來匹配單片機系統所需要的顯示數據格式。Image2Lcd支持的輸入影像格式包括： BMP, WBMP, JPG, GIF, WMF, EMF, ICO, 等等。Image2Lcd的輸出數據類型包括定制的二進位類型、C語言數組類型和標準的BMP格式、WBMP格式。Image2Lcd能可視調節輸入影像的數據掃描方式、灰度(顏色數)、影像數據排列方式、亮度、對比度、等等。對于包含了影像頭數據保存的影像數據檔案，Image2Lcd能重新開啟作為輸入影像。

特點

  • 支持所有的點陣LCD所需要的特殊顯示數據格式。
  • 可視調節輸出影像效果。
  • 256色模式下支持用戶調色板(TIFF格式)。
  • 支持4096色影像輸出。
  • 以二進位類型和C語言數組類型(文本)兩種方式保存數據，方便單片機開發者的不同需要。
  • 保存的數據支持LSB First/MSB First(很多單片機系統WORD高低位元組排列與PC相反)。
  • 可以保存影像為指定顏色數的BMP格式影像。
  • 即時圖示當前設定的數據格式。


窗口界面介紹

Image2Lcd 窗口界面如下圖所示：

Image2Lcd窗口包含工具列、影像設定區、影像顯示區、影像調整區、狀態列。

工具列：
工具列包含有按鈕：開啟、保存、設定、重新載入、上一幅、下一幅、幫助、關於。

  • 開啟：開啟影像檔案作為輸入影像。
  • 保存：以當前設定的格式保存輸出影像數據。
  • 設定：啟動設定對話框。
  • 重新載入：重新開啟輸入影像，并按照當前設定轉換成輸出影像。
  • 上一幅：開啟當前影像所在目錄中的上一幅影像。
  • 下一幅：開啟當前影像所在目錄中的下一幅影像。
  • 幫助：啟動幫助文檔。
  • 關於：啟動關於對話框。

影像設定區：
設定區包含一組用來設定輸出影像格式的控制項，在頂部的方框中影像是當前設定的影像數據格式的圖解說明。詳細說明見設定輸出影像格式。

影像顯示區：
影像顯示區分為左右兩個部分，左邊的部分顯示輸入影像，右邊的部分顯示輸出影像，輸出影像是由輸入影像按照當前設定的數據格式轉變得到顯示數據并顯示。如果輸入影像超過用戶設定的最大寬度或最大高度。輸入影像將被比例縮小到最大寬度和最大高度之內。

影像調整區：
影像調整區有頁面：輸出影像調整、256色、16位彩色、18位彩色、24位彩色、32位彩色，在未注冊狀態下還有頁面：注冊。

  • 輸出影像調整：調整輸出影像的顯示效果。
  • 256色：設定256色下的調色板。
  • 4096色：設定4096色下的RGB顏色排列。
  • 16位彩色：設定16位彩色下的RGB顏色排列。
  • 18位彩色：設定18位彩色下的RGB顏色排列。
  • 24位彩色：設定24位彩色下的RGB顏色排列。
  • 32位彩色：設定32位彩色下的RGB顏色排列。
  • 注冊：注冊Image2Lcd軟體。

狀態列：
狀態列顯示輸入影像和輸出影像的資訊,左邊部分顯示輸入影像名和原始圖片的寬度和高度，右邊部分顯示輸出影像的寬度和高度。


設定對話框

設定對話框界面如下圖所示：

設定對話框包含兩項設定內容。

在資源管理器右鍵功能表中設定關連功能表：
這一項選中后，在資源管理器中的影像檔案名上點擊右鍵后出現的功能表中添加一項“Image2Lcd”。選中該項將啟動Image2Lcd開啟該影像檔案。

保存為(*.C)檔案后使用記事本開啟：
在輸出數據類型為“C語言數組(*.C)”時, 在保存輸出數據后，輸出數據檔案使用記事本開啟顯示。


設定輸出影像格式

輸出影像格式包含如下設定內容：

輸出數據類型：
可以選擇的項有：“二進位(*.bin)”，“C語言數組(*.c)”，“BMP格式(*.bmp)”，“WBMP格式(*.wbmp)”。

掃描模式：
可以選擇“水平掃描/垂直掃描/數據水平,位元組垂直/數據垂直,位元組水平”中的一種。

輸出灰度：
可以選擇“單色/4灰/16灰/256色/4096色/16位真彩色/18位真彩色/24位真彩色/32位真彩色”中的一種。

最大寬度、最大高度：
設定輸出影像的最大寬度和高度，點擊緊靠著的箭頭按鈕或重新載入按鈕使當前開啟的影像適應新設定的最大寬度和最大高度。

包含影像頭數據：
在輸出數據類型為“二進位(*.bin)”或“C語言數組(*.c)”時保存的影像數據包含有影像頭數據，只有包含了影像頭數據的檔案Image2Lcd才能重新開啟顯示。詳見影像頭數據結構。

位元組內象素數據反序：
在“單色/4灰/16灰”時位元組內的象素數據從低位向高位排列。

自右至左掃描：
掃描模式的附加選項，影響輸出影像數據排列方式。當前使用的數據排列見窗口左上方的示意圖。

自底至頂掃描：
掃描模式的附加選項，影響輸出影像數據排列方式。當前使用的數據排列見窗口左上方的示意圖。

高位在前(MSB First)：
使保存的數據中WORD類型的數據高低位位元組顛倒(和PC中的高低位位元組相反)。很多微處理器對WORD類型的高低位位元組順序定義和PC(X86 CPU)相反，此時選中此項，在微處理器中讀出WORD類型數據時就可以直接使用而不需要顛倒高低位元組了。


影像頭數據結構

Image2Lcd保存的影像數據組織方式為：影像頭數據-調色板數據-影像數據。

“單色/4灰/16灰/256色”的影像數據頭如下：

typedef struct _HEADGRAY
{
unsigned char scan;
unsigned char gray;
unsigned short w;
unsigned short h;
}HEADGRAY;

scan: 掃描模式

  • Bit7: 0:自左至右掃描，1:自右至左掃描。
  • Bit6: 0:自頂至底掃描，1:自底至頂掃描。
  • Bit5: 0:位元組內象素數據從高位到低位排列，1:位元組內象素數據從低位到高位排列。
  • Bit4: 0:WORD類型高低位位元組順序與PC相同，1:WORD類型高低位位元組順序與PC相反。
  • Bit3~2: 保留。
  • Bit1~0: [00]水平掃描，[01]垂直掃描，[10]數據水平,位元組垂直，[11]數據垂直,位元組水平。
gray: 灰度值

灰度值，1:單色，2:四灰，4:十六灰，8:256色，12:4096色，16:16位彩色，24:24位彩色，32:32位彩色。

w: 影像的寬度。

h: 影像的高度。

“4096色/16位真彩色/18位真彩色/24位真彩色/32位真彩色”的影像數據頭如下：

typedef struct _HEADCOLOR
{
unsigned char scan;
unsigned char gray;
unsigned short w;
unsigned short h;
unsigned char is565;
unsigned char rgb;
}HEADCOLOR;

scan、gray、w、h與HEADGRAY結構中的同名成員變數含義相同。

is565: 在4096色模式下為0表示使用[16bits(WORD)]格式，此時影像數據中每個WORD表示一個象素；為1表示使用[12bits(連續位元組流)]格式，此時連續排列的每12Bits代表一個象素。
在16位彩色模式下為0表示R G B顏色分量所占用的位數都為5Bits，為1表示R G B顏色分量所占用的位數分別為5Bits,6Bits,5Bits。
在18位彩色模式下為0表示"6Bits in Low Byte"，為1表示"6Bits in High Byte"。
在24位彩色和32位彩色模式下is565無效。

rgb: 描述R G B顏色分量的排列順序，rgb中每2Bits表示一種顏色分量，[00]表示空白，[01]表示Red，[10]表示Green，[11]表示Blue。

“256色”的調色板數據結構如下：

typedef struct _PALENTRY
{
unsigned char red;
unsigned char green;
unsigned char blue;
}PALENTRY;

typedef struct _PALETTE
{
unsigned short palnum;
PALENTRY palentry[palnum];
}PALETTE;

僅在256色模式下存在調色板數據結構,調色板數據結構緊跟在數據結構HEADGRAY之后。


影像數據說明

Image2Lcd保存的影像數據組織方式為：影像頭數據-調色板數據-影像數據。
影像頭數據和調色板數據的格式見影像頭數據結構。
當前設定的影像格式的數據排列方式在程式界面的左上角有圖形描述。
影像數據的排列方式受 掃描模式、位元組內象素數據反序、自右至左掃描、自底至頂掃描等設定的影響。
設定中選擇“位元組內象素數據反序”表示灰度影像數據的位元組內部影像數據從低位向高位順序排列，否則影像數據從高位向低位順序排列。
設定中選擇“自右至左掃描”表示影像數據從影像的右邊開始向左邊方向排列，否則影像數據從影像的左邊開始向右邊方向排列。
設定中選擇“自底至頂掃描”表示影像數據從影像的底部開始向頂部方向排列，否則影像數據從影像的頂部開始向底部方向排列。

“單色”的影像數據：

單色影像數據一個象素使用一個位(1 Bit)表示，0表示白色，1表示黑色。由于數據的最小存儲單位是位元組，每個位元組有8個位，當影像的寬或高不是8的倍數時，影像數據的寬或高將補0擴充到8的倍數以吻合位元組寬度(具體是寬度還是高度取決于掃描模式)。

“4灰”的影像數據：

4灰影像數據一個象素使用兩個位(2 Bit)表示，00表示白色，01表示淺灰色，10表示深灰色，11表示黑色。由于數據的最小存儲單位是位元組，每個位元組有8個位，當影像的寬或高不是4的倍數時，影像數據的寬或高將補0擴充到4的倍數以吻合位元組寬度(具體是寬度還是高度取決于掃描模式)。

“16灰”的影像數據：

16灰影像數據一個象素使用四個位(4 Bit)表示，影像數據[0X00~0X0F]代表的顏色從白色到黑色漸變。由于數據的最小存儲單位是位元組，每個位元組有8個位，當影像的寬或高不是2的倍數時，影像數據的寬或高將補0擴充到2的倍數以吻合位元組寬度(具體是寬度還是高度取決于掃描模式)。

“256色”的影像數據：

256色影像數據一個象素使用一個位元組表示。影像數據的每個位元組記錄的是對應的象素在調色板中的條目， 調色板中每一條目都記錄了一種用RGB描述的顏色。調色板條目個數最大值為256個(0~255)。調色板在256色數據調整中設定。

“4096色”的影像數據：

4096色影像數據一個象素使用12個位(12 Bits)表示。該12Bits記錄了對應的象素RGB顏色。 R G B顏色分量分別占用4Bits，排列順序由4096色數據調整設定。

“16位真彩色”的影像數據：

16位真彩色影像數據一個象素使用一個WORD(2 Bytes)表示。影像數據的每個WORD記錄了對應的象素RGB顏色。 R G B顏色分量數值在WORD中的位置由16位彩色數據調整設定。WORD類型數據同時 受設定“WORD高位元組低地址”的影響，選中此項將使WORD的高低位元組順序與PC定義相反。

“18位真彩色”的影像數據：

18位真彩色影像數據一個象素使用3個Byte表示。這3個Byte數據分別記錄了象素的RGB顏色分量。 R G B顏色分量數值在3個Byte中的位置排列由18位彩色數據調整設定。

“24位真彩色”的影像數據：

24位真彩色影像數據一個象素使用三個位元組(3 Bytes)表示。影像數據的每三個位元組記錄了對應的象素RGB顏色。 R G B顏色分量分別占用一個位元組，排列順序由24位彩色數據調整設定。

“32位真彩色”的影像數據：

32位真彩色影像數據一個象素使用四個位元組(4 Bytes)表示。影像數據的每四個位元組記錄了對應的象素RGB顏色。 R G B顏色分量分別占用一個位元組，另一個位元組為0。排列順序由32位彩色數據調整設定。


輸出影像調整

輸出影像調整的界面部分如下圖顯示：

恢復預設值
點擊恢復預設值按鈕使輸出影像調整參數回到預設設定，即正常顯示、顏色不反轉、亮度和對比度等同輸入影像。

顏色反轉
顏色反轉單選框被選中后，輸出影像的顏色數據被做取反操作。

顯示方式
右上角的下拉框中列出了四種可選輸出影像顯示方式：正常顯示、左右顛倒、上下顛倒和左右上下顛倒。

亮度
拖動亮度滑塊調整輸出影像的亮度。

對比度
拖動對比度滑塊調整輸出影像的對比度。


256色數據調整

256色數據調整的界面部分如下圖顯示：

調色板選擇
可選擇RGB332調色板、灰度調色板、用戶調色板。其中用戶調色板是用戶指定的調色板檔案(TIFF格式)。當前選擇的調色板的顏色順序在下部的色條中被顯示。

輸出影像數據中包含調色板數據
256色影像數據只有配合調色板數據才能正常顯示(LCD控制器使用預設的調色板時例外)，建議用戶選上此項。當LCD控制器支持RGB332格式的8位顏色數據時，選擇 RGB332調色板、不選 輸出影像數據中包含調色板數據，此時影像數據正好吻合RGB332格式。調色板數據結構見影像頭數據結構中的說明。

載入調色板
該按鈕用來開啟一個調色板檔案(*.PAL)作為用戶調色板。開啟的用戶調色板檔案名將顯示在左邊的編輯框中。用戶也能使用256色的BMP檔案(*.BMP)作為調色板檔案開啟。

保存調色板
用來保存當前選擇的調色板數據為TIFF格式(*.PAL)檔案。

調色板直觀圖
用來直觀顯示當前選擇的調色板的顏色順序。


4096色數據調整

4096色數據調整的界面部分如下圖顯示：

恢復預設值
點擊恢復預設值按鈕使調整參數回到預設設定，即顏色位數為16Bits(WORD)，顏色數據排列由高位到低位依此為NULL,Red,Green,Blue。

顏色位數
4096色影像數據每一象素使用一個12Bits數據來表示，每4Bits數據記錄象素的紅綠藍顏色分量中的一種，Image2Lcd支持兩種應用普遍的顏色位數格式，分別是[12bits(連續位元組流)]和[16bits(WORD)]，其中第二種格式會使WORD中剩余4Bits，稱為空白位，空白位在顏色數據排列圖中以白色表示。

顏色數據排列
圖示4096色影像的一個象素數據從高位到低位的顏色分量排列順序。用滑鼠拖動顏色塊來改變排列方式。顏色位數為[16bits(WORD)]時，作為WORD型數據，在保存時還將受設定輸出影像格式中的“高位在前(MSB First)”影響。


16位彩色數據調整

16位彩色數據調整的界面部分如下圖顯示：

恢復預設值
點擊恢復預設值按鈕使調整參數回到預設設定，即顏色位數為[R:5bits,G:6bits,B:5bits]，顏色數據排列由高位到低位依此為Red,Green,Blue。

顏色位數
16位彩色影像數據每一象素使用一個WORD數據來表示，這個WORD數據中記錄了象素的紅綠藍三種顏色分量的值，Image2Lcd支持兩種應用普遍的顏色位數格式，分別是[R:5bits,G:6bits,B:5bits]和[R:5bits,G:5bits,B:5bits]，其中第二種格式會使WORD中剩余一bit，稱為空白位，空白位在顏色數據排列圖中以白色表示。

顏色數據排列
圖示16位彩色一個WORD影像數據從高位到低位的顏色分量排列順序。用滑鼠拖動顏色塊來改變排列方式。作為WORD型數據，在保存時還將受設定輸出影像格式中的“高位在前(MSB First)”影響。


24位彩色數據調整

24位彩色數據調整的界面部分如下圖顯示：

恢復預設值
點擊恢復預設值按鈕使24位彩色影像的顏色數據排列回到預設設定，即Blue,Green,Red的順序。

顏色數據排列
24位彩色的影像數據每一象素對應24bits即三個位元組，其中每個位元組對應一種顏色分量。在圖示中從左到右依此為bytes[0~2]所代表的顏色分量，使用滑鼠拖動顏色塊來改變排列方式。


32位彩色數據調整

32位彩色數據調整的界面部分如下圖顯示：

恢復預設值
點擊恢復預設值按鈕使32位彩色影像的顏色數據排列回到預設設定，即Blue,Green,Red,空白位的順序。

顏色數據排列
32位彩色的影像數據每一象素對應32bits即四個位元組，其中三個位元組對應一種顏色分量，一個位元組不用稱為空白位。空白位在圖中以白色表示。圖示中從左到右依此為bytes[0~3]所代表的顏色分量或空白位，可以使用滑鼠拖動顏色塊來改變排列方式。


安裝說明

下載了Image2Lcd安裝程式后，解壓縮數據并按兩下Setup程式，按照提示完成安裝步驟就可以了。

Image2Lcd安裝后將在開始功能表的程式組和桌面上出現功能表項或圖標，這時Image2Lcd處于沒有注冊的狀態。對于已經獲得注冊碼的用戶，運行Image2Lcd程式并輸入注冊碼后程式轉入注冊狀態。


運行環境

Image2Lcd對系統有如下要求：

  • 中文版本的Windows95/98/2000/NT/XP。
  • 奔騰133M以上的CPU。
  • 32M以上的記憶體。
  • 16位顏色以上的彩色模式。
  • IE5.0以上的版本。
  • DirectX 5.0以上的版本。
  • 滑鼠必備。


卸載

有兩種方法可以卸載Image2Lcd。

控制面板
運行控制面板程式，按兩下添加/移除程式，在添加/移除程式的列表框中找到Image2Lcd條目并按兩下，或選中Image2Lcd條目后點擊添加/移除按鈕。

開始功能表
開啟開始功能表，依此開啟程式、Image2Lcd，然后運行Uninstall Image2Lcd。


如何注冊

Image2Lcd的未注冊版本關於注冊的頁面如下圖顯示：

訪問注冊網頁
點擊該鏈接將啟動IE窗口并鏈接到Image2Lcd的注冊網頁，通過注冊網頁來申請注冊獲得注冊碼。

訪問作者主頁
點擊該鏈接將啟動IE窗口并鏈接作者的的主頁，用戶可以訪問作者主頁來了解Image2Lcd的升級資訊和得到技術支持。

給作者發郵件
有關於Image2Lcd的問題、建議歡迎發郵件給作者。

注冊碼
當通過注冊網頁注冊并收到注冊碼郵件后把收到的注冊碼填入注冊碼編輯框，點擊[注冊]按鈕來完成注冊。

注冊
[注冊]按鈕用來在填好注冊碼后的注冊。當注冊碼無誤時Image2Lcd提示成功注冊資訊，當注冊碼不正確時提示出錯資訊。

Image2Lcd的一個注冊碼只授權給一臺PC使用，未注冊的版本將在輸入輸出影像上加上“Image2Lcd”字樣，注冊后該字樣將立即永久消失。注冊后請保存好您的注冊碼，以備重新安裝Image2Lcd之用。另外，開啟About對話框可以看到注冊情況的資訊顯示。


聯系作者

技術支持: wwwbbbjjj@sohu.com
注冊銷售: 進入注冊網頁

升級資訊請關注:
http://www.wbj3000.com


License

END-USER LICENSE AGREEMENT FOR THIS SOFTWARE

This End-User License Agreement ("EULA") is a legal agreement between you (either an individual or a single entity) and the mentioned author of this Software for the software product identified above, which includes computer software and may include associated media, printed materials, and "online" or electronic documentation ("SOFTWARE PRODUCT"). By installing, copying, or otherwise using the SOFTWARE PRODUCT, you agree to be bound by the terms of this EULA. If you do not agree to the terms of this EULA, do not install or use the SOFTWARE PRODUCT.

SOFTWARE PRODUCT LICENSE
The SOFTWARE PRODUCT is protected by copyright laws and international copyright treaties, as well as other intellectual property laws and treaties. The SOFTWARE PRODUCT is licensed, not sold.

1. GRANT OF LICENSE. This EULA grants you the following rights:Installation and Use. You may install and use an unlimited number of copies of the SOFTWARE PRODUCT.

Reproduction and Distribution. You may reproduce and distribute an unlimited number of copies of the SOFTWARE PRODUCT; provided that each copy shall be a true and complete copy, including all copyright and trademark notices, and shall be accompanied by a copy of this EULA. Copies of the SOFTWARE PRODUCT may be distributed as a standalone product or included with your own product.

2. DESCRIPTION OF OTHER RIGHTS AND LIMITATIONS.

Limitations on Reverse Engineering, Decompilation, and Disassembly. You may not reverse engineer, decompile, or disassemble the SOFTWARE PRODUCT, except and only to the extent that such activity is expressly permitted by applicable law notwithstanding this limitation.

Separation of Components.
The SOFTWARE PRODUCT is licensed as a single product. Its component parts may not be separated for use on more than one computer.

Software Transfer.
You may permanently transfer all of your rights under this EULA, provided the recipient agrees to the terms of this EULA.

Termination.
Without prejudice to any other rights, the Author of this Software may terminate this EULA if you fail to comply with the terms and conditions of this EULA. In such event, you must destroy all copies of the SOFTWARE PRODUCT and all of its component parts.

Distribution.
The SOFTWARE PRODUCT may not be sold or be included in a product or package which intends to receive benefits through the inclusion of the SOFTWARE PRODUCT. The SOFTWARE PRODUCT may be included in any free or non-profit packages or products.

3. COPYRIGHT.
All title and copyrights in and to the SOFTWARE PRODUCT(including but not limited to any images, photographs, animations, video, audio, music, text, and "applets" incorporated into the SOFTWARE PRODUCT), the accompanying printed materials, and any copies of the SOFTWARE PRODUCT are owned by the Author of this Software. The SOFTWARE PRODUCT is protected by copyright laws and international treaty provisions. Therefore, you must treat the SOFTWARE PRODUCT like any other copyrighted material except that you may install the SOFTWARE PRODUCT on a single computer provided you keep the original solely for backup or archival purposes.

LIMITED WARRANTY

NO WARRANTIES.
The Author of this Software expressly disclaims any warranty for the SOFTWARE PRODUCT. The SOFTWARE PRODUCT and any related documentation is provided "as is" without warranty of any kind, either express or implied, including, without limitation, the implied warranties or merchantability, fitness for a particular purpose, or noninfringement. The entire risk arising out of use or performance of the SOFTWARE PRODUCT remains with you.

NO LIABILITY FOR DAMAGES.
In no event shall the author of this Software be liable for any damages whatsoever (including, without limitation, damages for loss of business profits, business interruption, loss of business information, or any other pecuniary loss) arising out of the use of or inability to use this product, even if the Author of this Software has been advised of the possibility of such damages.

LIMITATIONS OF UNREGISTERED VERSION

You can use the SOFTWARE PRODUCT for evaluation purposes. The unregistered copy of SOFTWARE PRODUCT will add a mark (Image2Lcd) when you converted and saved images.

REGISTRATION

The SOFTWARE PRODUCT is not a free software. You are licensed to use one copy of SOFTWARE PRODUCT, on one (1) computer or workstation. See the SOFTWARE PRODUCT web site at http://www.wbj3000.com for more information about online ordering. When payment is received you will be sent a registration number of latest version of SOFTWARE PRODUCT.


18位彩色數據調整

18位彩色數據調整的界面部分如下圖顯示：

恢復預設值
點擊恢復預設值按鈕使調整參數回到預設設定，即顏色位數為"6Bits in Low Byte"，顏色數據排列由高位到低位依此為Blue,Green,Red。

顏色位數
18位彩色影像數據每一象素使用3個Byte數據來表示，這3個Byte數據分別記錄了象素的紅綠藍三種顏色分量的值，由于每種顏色分量只使用了6個Bits，每個Byte還多出2個Bits，稱為空白位，空白位在顏色數據排列圖中以白色表示。 空白位的位置隨顏色位數設定而改變，當選"6Bits in Low Byte"時，空白位在位元組的高2位，當選"6Bits in High Byte"時，空白位在位元組的低2位。

顏色數據排列
圖示18位彩色一個象素的影像數據(3Bytes)的顏色分量排列順序。用滑鼠拖動顏色塊來改變排列方式。輸出的影像數據將按圖示的顏色分量的排列方式來組織數據。